suffolk Browser Detection


Detecting Browser...Please Wait


Financial CounselorTM 4.0 Requirements:


  • Netscape Navigator/Communicator 3.0 and higher
    ...or...
  • Microsoft Internet Explorer 4.0 and higher

  • JavaScript Enabled

    It appears that your browser does not meet all of these requirements. Please use either of the buttons below to upgrade your browser. If your browser meets these requirements verify that javascript is enabled.